Translate Toolkit & Pootle

Tools to help you make your software local

User Tools


Sviluppo di Pootle

Requisiti

Pootle è scritto in Python e richiede la versione 2.3 o superiore.

Esso richiede anche jToolkit che viene usato per generare pagine web e richiede un web server. Si noti che la home page di jToolkit home page non è aggiornata, il codice sorgente più recente è diponibile attraverso Pootle (vedi sotto)

Codice sorgente

Pootle è sviluppato nello stesso CVS repository di index, susrc/trunk/Pootle

Ogni tanto dei tarballs contenenti il codice più aggiornato (sia per Pootle che jToolkit) vengono messi su http://davidf.sjsoft.com/pootle/

Installazione

Estraete il codice sorgente di jToolkit e Pootle, ed eseguite i programmi di setup (le date potrebbero essere differenti):

tar xzf ./jToolkit-0.6.2005.0217.tar.gz
cd jToolkit-0.6.2005.0217
python jToolkitSetup.py install
cd ..
tar xzf ./Pootle-0.8.2005.0217.tar.gz
cd Pootle-0.8.2005.0217
python setup.py install

Per eseguire, editate pootle.prefs e sistemate i vostri file PO, e lanciate pootle.py nella directory in cui è stato installato (qui sono necessarie più informazioni)

Documentazione

Il Pootle HOWTO è ora disponibile nel wiki

Sviluppi futuri

Si veda PootleTODO per le cose che devono ancora essere fatte. Una vista a più alto livello è disponibile in PootleRoadmap