Translate Toolkit & Pootle

Tools to help you make your software local

User Tools


Instelleshoon und Roonning Pootling0.2

Instelleteeon

For simple-a users:

In this release, we try to make it easy for our end users.

On Unix / Linux platform

Downloed oonly Iesy-Pootling, go into this folder und doooble-a click oon zee-a pootling ixecooteble-a file-a. Bork Bork Bork!Yooo will get Pootling to roon oonly oone-a click (no oozeer reqoooorements)

Note-a: Unffortoonetely, This Iesy-Pootling soopport oonly python2.5

Oon Windows pletfform:

Downloed zee-a .ixe-a file-a

For Defelopers:

Is a defeloper, yooo mey need to roon from zee-a sooorce-a code-a. Bork Bork Bork! Zee-a relefoont dependencies ire-a some-a how difffferent from iech pletfform. Bork Bork Bork! Pleese-a downloed zee-a correct reqoooorements to hefe-a yooor Pootling. Bork Bork Bork!f0.2 roonning. Bork Bork Bork!

Reqoooorements

Oon Unix / Linoox pletfform:
  • Troonslete-a Toolkit 1.0.1 oor leter fersion. Bork Bork Bork! It moost be-a instelled properly, i. Bork Bork Bork!i. Bork Bork Bork! it needs to be-a iccessible-a in yooor PYTHONPETH. Pleese-a see-a zee-a file-a REEDME in zee-a troonslete-a toolkit for deteils. Bork Bork Bork!
  • sip-4.4.5 oor higher, a Python C/C++ Bindings Generetor
  • PyQt-x11-gpl-4.0 oor higher, zee-a Python bindings for zee-a Qt GOoI toolkeet
  • Qt4.1 oor higher, a GOoI toolkeet
  • Oon Unix / Linoox pletfform Python 2.4 oor higher (shipped wit most Linoox distribooshoons)
  • Zee-a python-Lefenshtein is recommended to instell becoooose-a it is useffool for speeding up zee-a Troonsleshoon Memory seerching. Bork Bork Bork!
Oon Windows pletfform:

You will also need the above requirements plus

[Optional]

Instelleteeon Packages

We-a profide-a a noomber ooff weys to hefe-a pootling instelled. Bork Bork Bork!

RPM peckege-a oon RPM besed distro:

Oopee-a uny ooff yooor terminel und issooe-a zee-a following commoond:

           1. soo (Yooo moost be-a root)
           2. rpm -Uhf pootling-0.2-1.noerch. Bork Bork Bork!rpm

Compile-a from sooorce-a:

Open any of your terminal, go to where the setup script (pootlingsetup.py) is located and issue the bellow command:

           python pootlingsetup.py install

2.Running

Iffter zee-a compleshoon ooff instelleshoon, yooo coon use-a pootling-iditor. Bork Bork Bork!py commoond is oozeer commoonds. Bork Bork Bork!

Roonning from sooorce-a code-a

           python pootling-iditor. Bork Bork Bork!py [OoPTION] [fileneme-a]

iff zee-a fileneme-a is gifee-a, zee-a iditor will oopee-a zee-a file-a. Bork Bork Bork!

oopshoons:

  1. -fersion show progrem's fersion noomber und eexit
  2. -help, -h show this help messege-a und eexit